jmop

Einen Moment…

jmop header image 2

LEGO Mindstorms NXT 2.0 auf dem Mac

Januar 18th, 2011 · No Comments

Steht zumindest auf der Packung: „minimum system requirements: Apple Macintosh, Mac OS X 10.4 or 10.5“ Die Praxis sieht leider anders aus.

Unser ältester Sohn hatte nun schon länger gespart um sich einen Lego Mindstorms NXT 2.0 kaufen zu können. Zu Weihnachten war es dann soweit, das Geld hatte er zusammen. Mit seinen neun Jahren ist aber noch etwas jung, um sich mit den verschiedenen Problemen gleichzeitig auseinander zu setzen: zum einen muss man ein Modell bauen, zum anderen muss man natürlich die Programmierung durchführen.
Die Lösung sollte so aussehen, dass wir uns gemeinsam daran machen, die Programmierung durchzuführen. Auf der Packung stand, dass die Software auch für Mac OS X 10.5 geeignet sei, also kein Problem, oder? Installiert, gestartet und los geht’s, dachte ich! Dumm nur, dass unter 10.5.8. beim Starten der Software der Fehlercode 1003 ausgegeben wurde und sich das Programm anschließend direkt wieder beendet hat. Eine erste Webrecherche hat nur Hinweise hervorgebracht, die nicht zu helfen schienen. Bei anderen Mac-Usern dagegen schon, also musste bei mir doch etwas anders sein – aber was?!
Auf der Seite http://thenxtstep.blogspot.com/2009/09/snow-leopard-issues-interim-fix.html standen Hinweise für 10.6 – würde das vielleicht meine Probleme lösen, wenn ich auf 10.6 umsteige? Gesagt getan, doch das Problem war damit nicht aus der Welt – das Ergebnis war nämlich dasselbe.
Die Kommentare auf der Seite schienen auch nicht weiter Hilfreich, bis ich einen Hinweis auf das verwendete Dateisystem fand – nämlich, dass bei Verwendung von HFS+ mit Beachtung der Groß- und Kleinschreibung muss man mehr tun:

1. Get and run the Snow Leopard patch from http://mindstorms.lego.com/en-us/support/files/Advanced.aspx#Patches

2. Get and install the Fantom driver from http://mindstorms.lego.com/en-us/support/files/Advanced.aspx#Driver

3. Open a shell window and use this command:
sudo ln -s /Library/Frameworks/Fantom.framework /Library/Frameworks/fantom.framework

Nun funktioniert die Software zumindest, doch dann das nächste Problem: bei den Symbolen (vollständige Palette) werden beim Ausklappen teilweise leere Flächen angezeigt anstelle der eigentlichen Symbole. Verwendet man eines dieser leeren Symbole, dann erhält man aber tatsächlich das fehlende Steuerungselement. Mindestens das Symbol für „Motor“ und „Berührungssensor“ fehlen hier, in „Allgemeine Palette“ fehlt das „Warten“-Symbol.
Fehlendes Symbol Na ja, so ist die Software nicht zu gebrauchen. Eine Mail an Lego wurde bislang nicht beantwortet, schade.
Was für ein Glück, dass wir auf den PC von Mama ausweichen konnten und dass die Software unter Windows 7 gut zu funktionieren scheint. Ärgerlich ist es aber schon, dass man ein so teures Produkt erwirbt und die Software einfach nicht funktioniert.

Tags: Allgemein · os x

0 responses so far ↓

  • There are no comments yet...Kick things off by filling out the form below.

Leave a Comment